



  

<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.winchesterstar.com/content/tncms/live/" />
<meta name="keywords" content="obituaries" />
<meta name="news_keywords" content="obituaries" />
<meta name="description" content="Allen D. Barr, Jr., 53, of Frederick County, Virginia, passed away Saturday, February 22, 2020, at his home surrounded by his family." />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.winchesterstar.com/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/5/82/582733aa-8259-59c3-bd4c-b64a441f873f/5e5426566a89f.image.jpg?resize=314%2C400" />
<meta property="og:image:width" content="314" />
<meta property="og:image:height" content="400" />
<meta property="og:title" content="Allen D. Barr, Jr." />
<meta property="og:description" content="Allen D. Barr, Jr., 53, of Frederick County, Virginia, passed away Saturday, February 22, 2020, at his home surrounded by his family." />
<meta property="og:site_name" content="The Winchester Star" />
<meta property="og:section" content="Obituaries" />
<meta property="article:publisher" content="http://www.facebook.com/pages/The-Winchester-Star/195641831897" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@WinStarVa" />
<meta name="twitter:image:alt" content="Allen D. Barr, Jr." />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.5d2fa7c9eef08e25d7b299bf6e6a0e31.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.f5e0209e8fa74e9037c8703df61fdb9c.css"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/live/global/resources/styles/site.css?_dc=1471535285"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:400,600"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:400,700"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Droid+Serif:300,400,700"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-text-promo.945a2efac4892ce469180c513f411107.css"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.159.0"},"page":{"grid":"boxy","style":"default","path":"\/obituaries","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"system":{"render_time":243},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0","app":"editorial"},"google":{"ua":"UA-5857610-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.c34c594a0128ca26764dd8ecad278707.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.85fd144868f04603b8184a52aac0096a.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.caf244e2614d000b4f73058e1c610d12.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/ads/impressions.js?_dc=1582673855.temp"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/ads/traffic.js?_dc=1582609018"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/ads/settings.js?_dc=1519927762"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/live/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.js?_dc=1512493074"></script>

            
            <title>Allen D. Barr, Jr. | Obituaries | winchesterstar.com</title>
            
    <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.winchesterstar.com/content/tncms/site/icon.ico" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//s.yimg.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Allen D. Barr, Jr. | Obituaries | winchesterstar.com" href="http://www.winchesterstar.com/search/?f=rss&amp;t=article&amp;c=obituaries&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.winchesterstar.com/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html" />
            
    <script defer src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a8c7e0dc594b3a0b53141cdea833eee5.js"></script>
            



    	<script type='text/javascript'>
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
		(function() {
			var gads = document.createElement('script');
			gads.async = true;
			gads.type = 'text/javascript';
			var useSSL = 'https:' == document.location.protocol;
			gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
			var node = document.getElementsByTagName('script')[0];
			node.parentNode.insertBefore(gads, node);
		})();
	</script>


        <script type='text/javascript'>

                /* get the main category to use for the MSection variable */
                var root_path = unescape(document.location.pathname);
                root_path.indexOf(1);			
                root_path.toLowerCase();				
                root_path = root_path.split("/")[1];
                var root_path = '/' + root_path;
                var root_path = root_path.replace(/[^a-z0-9\/]|\s+|\r?\n|\r/gmi, "_");
                if ( root_path == '/' ) {
                    root_path = '/homepage';
                }

                /* full_path comes from a TownNews provided variable */
                var full_path = '/obituaries';
                if ( full_path == '/' ) {
                    full_path = '/homepage';
                }


                console.log("MSection = " + root_path);
                console.log("SubSection = " + full_path);



                googletag.cmd.push(function() {
		googletag.pubads().setTargeting('SiteID','WSWV'); 	/* Define in Functions */
		googletag.pubads().setTargeting('MSection',root_path); 	/* top lvl parent */
		googletag.pubads().setTargeting('SubSection',full_path);/* current lvl parent */
		});
	</script>

	<script type='text/javascript'>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</script>


    <script>
        /*AMAZON PUBLISHER SERVICES*/
        //load the apstag.js library
        !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

        //initialize the apstag.js library on the page to allow bidding
        apstag.init({
            pubID:  '729ce0ef-27ae-4112-a6f1-52cb2c548a08', //enter your pub ID here as shown above, it must within quotes
            adServer: 'googletag',
            simplerGPT: true
        });
    </script>

    <script>
        /*AMAZON PUBLISHER SERVICES*/
        googletag.cmd.push(function(){
            apstag.fetchBids({
                    timeout: 4000 },
                function(bids) {
                    apstag.setDisplayBids();
                    googletag.pubads().refresh();
                });
        });
    </script>



<script type="text/javascript">
$(document).ready(function(){
 $('#user-main-menu-wrapper > div > div.col-md-9.col-md-push-3 > div.user-dashboard > div:nth-child(3) > div > div > a').attr("href","https://classadz.vdata.com/Legacy/WinchesterStar/Circulation/Subscriber");
 $('#user-main-menu-wrapper > div > div.col-md-9.col-md-push-3 > div.user-dashboard > div:nth-child(2) > div > div > a:contains("Subscriptions")').attr("href","https://classadz.vdata.com/Legacy/WinchesterStar/Circulation/Subscriber");
 $('.row.logged-in > div > a:contains("Purchase a Subscription")').text("Subscribe");
 
 $('#user-main-menu-wrapper > div > div.col-md-9.col-md-push-3 > legend.form-review-legend:contains("Receipt")').css("display","none");
 $('#user-main-menu-wrapper > div > div.col-md-9.col-md-push-3 > div:nth-child(5) > a:contains("Return to the page you were viewing")').text("Return to the home page");
 
$('div.panel-footer.user-signup.text-muted > a:contains("Register here")').text("Become a subscriber here"); 
  $('#collapse-subscription > a:nth-child(1)').attr("href","https://classadz.vdata.com/Legacy/WinchesterStar/Circulation/Subscriber");
 $('#collapse-subscription > a:nth-child(2)').attr("href","https://classadz.vdata.com/Legacy/WinchesterStar/Circulation/Subscriber");
 $("#card-classifieds-categories-460738 .panel-heading a[href*='/classifieds/job']").attr('href', 'http://winchestervirginiajobs.com/')
 
 
 
 
 
 


$('.ws-topstories-branded .card-label-section.text-muted').each(function(i){
    
    if( $.trim( $(this).text() ) == 'John Clawson - Waddell And Reed' ){
        
        $(this).text('JOHN CLAWSON - WADDELL & REED')
    }

});

 
 
 
 
});
</script><!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-wBzKXfxGbCQsY"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-wBzKXfxGbCQsY.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->


        </head>
        <body class="fixed-scroll-nav app-editorial grid-boxy blox-asset uuid-5570194b-ccc3-541a-a6a8-cd4628f9e0e0 section-obituaries type-article infinity-disabled">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.winchesterstar.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.159.0&tncms.page.grid=boxy&tncms.page.style=default&tncms.page.path=%2Fobituaries&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.vendor.outbrain=Headlines+and+photo+grid&tncms.vendor.taboola=&tncms.system.render_time=243&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.asset.id=5570194b-ccc3-541a-a6a8-cd4628f9e0e0&tncms.asset.app=editorial&tncms.google.ua=UA-5857610-1&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container">

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left visible-sm visible-xs">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-510405" class="tncms-block hidden-md hidden-lg"><section id="block-510405" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-510405" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-510405" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-510405-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-510405-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-510405-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-510405').submit();
        return false;
    });

    $('#site-search-510405').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-510405 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-510405 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-510405-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-510406" class="tncms-block hidden-md hidden-lg"><div id="user-controls-510406" class="user-controls show-onload clearfix default"><div class="large-user-avatar pull-left">
            <div class="tn-user-avatar pull-left"><!-- user avatar --></div>
        </div>
        <div class="large-user-controls pull-left">
            <div class="user-welcome">Welcome, <span class="tn-user-screenname">Guest</span></div><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.winchesterstar.com/users/signup/?referer_url=https%3A%2F%2Fwww.winchesterstar.com%2Fobituaries%2Fallen-d-barr-jr%2Farticle_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html" class=" user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.winchesterstar.com/users/login/?referer_url=https%3A%2F%2Fwww.winchesterstar.com%2Fobituaries%2Fallen-d-barr-jr%2Farticle_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html" class=" user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.winchesterstar.com/users/admin/">Dashboard</a></li>
                    <li><a class="logout-btn" onclick="document.getElementById('user-logout-form-510406').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <a class="dropdown-toggle  user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><span class="user-control-link">My Account</span>
                    <b class="caret user-control-link"></b>
                </a>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.winchesterstar.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.winchesterstar.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.winchesterstar.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-510406').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

    </div>

<form method="post" action="https://www.winchesterstar.com/users/logout/" id="user-logout-form-510406"><input type="hidden" name="referer_url" value="https://www.winchesterstar.com/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/news/winchester/"  class="nav-link tnt-section-winchester">Winchester</a>
                                </li><li>
                                    <a href="/news/frederick_county/"  class="nav-link tnt-section-frederick-county">Frederick County</a>
                                </li><li>
                                    <a href="/news/clarke_county/"  class="nav-link tnt-section-clarke-county">Clarke County</a>
                                </li><li>
                                    <a href="/wire/national/"  class="nav-link tnt-section-ap-national">AP National</a>
                                </li><li>
                                    <a href="/wire/state_region/"  class="nav-link tnt-section-ap-state-region">AP State Region</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/opinions/"  class="nav-link tnt-section-opinions">Opinions</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/opinions/our_view/"  class="nav-link tnt-section-our-view">Our View</a>
                                </li><li>
                                    <a href="/opinions/open_forums/"  class="nav-link tnt-section-open-forums">Open Forums</a>
                                </li><li>
                                    <a href="/opinions/letters/"  class="nav-link tnt-section-letters">Letters</a>
                                </li><li>
                                    <a href="/opinions/columns/"  class="nav-link tnt-section-political-columns">Political Columns</a>
                                </li><li>
                                    <a href="/opinions/cartoons/"  class="nav-link tnt-section-cartoons">Cartoons</a>
                                </li><li>
                                    <a   class="nav-link tnt-section-local-columns">Local Columns</a>
                                </li><li>
                                    <a   class="nav-link tnt-section-submit-an-opinion">Submit an Opinion</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/high_school"  class="nav-link tnt-section-high-school">High School</a>
                                </li><li>
                                    <a href="/sports/spotlights/"  class="nav-link tnt-section-spotlights">Spotlights</a>
                                </li><li>
                                    <a href="/sports/college"  class="nav-link tnt-section-college">College</a>
                                </li><li>
                                    <a href="/wire/sports/"  class="nav-link tnt-section-ap-sports">AP Sports</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/obituaries/"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-6" data-target="#mobile-nav-left_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/lifestyles/"  class="nav-link tnt-section-life">Life</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="/lifestyles/features/"  class="nav-link tnt-section-features">Features</a>
                                </li><li>
                                    <a href="/lifestyles/weekend/"  class="nav-link tnt-section-weekend">Weekend</a>
                                </li><li>
                                    <a href="/lifestyles/food/"  class="nav-link tnt-section-food">Food</a>
                                </li><li>
                                    <a href="/lifestyles/out_of_the_past/"  class="nav-link tnt-section-out-of-the-past">Out Of The Past</a>
                                </li><li>
                                    <a href="/lifestyles/bulletin_board/"  class="nav-link tnt-section-bulletin-board">Bulletin Board</a>
                                </li><li>
                                    <a href="/wire/entertainment/"  class="nav-link tnt-section-ap-entertainment">AP Entertainment</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-7" data-target="#mobile-nav-left_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-advertise-with-us">Advertise With Us</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a href="https://www.winchesterstar.com/site/forms/online_services/how_to_advertise_with_us/"  target="_blank" rel="noopener" class="nav-link tnt-section-how-to-advertise-with-us">How to Advertise With Us</a>
                                </li><li>
                                    <a href=" https://classadz.vdata.com/WinchesterStar/Advertising/Advertiser"  class="nav-link tnt-section-create-a-classified-ad">Create a Classified Ad</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-8" data-target="#mobile-nav-left_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a href="/notices/"  class="nav-link tnt-section-public-notices-and-legal-ads">Public Notices and Legal Ads</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-9" data-target="#mobile-nav-left_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="http://winchestervirginiajobs.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-jobs">Jobs</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a href="/employment/"  class="nav-link tnt-section-weekly-employment-display-ads">Weekly Employment Display Ads</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-10" data-target="#mobile-nav-left_menu-child-10">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-events">Events</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-10" class="collapse nav navbar-nav"><li>
                                    <a href="/calendar/"  class="nav-link tnt-section-see-the-calendar-page">See the Calendar Page</a>
                                </li><li>
                                    <a href="https://www.winchesterstar.com/users/admin/calendar/event/"  target="_blank" rel="noopener" class="nav-link tnt-section-submit-an-event">Submit an Event</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-11" data-target="#mobile-nav-left_menu-child-11">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-photos">Photos</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-11" class="collapse nav navbar-nav"><li>
                                    <a href="/photo/"  class="nav-link tnt-section-photo-galleries">Photo Galleries</a>
                                </li><li>
                                    <a href="http://winchesterstar.mycapture.com/mycapture/index.asp"  target="_blank" rel="noopener" class="nav-link tnt-section-order-photos">Order Photos</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-12" data-target="#mobile-nav-left_menu-child-12">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-access">Access</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-12" class="collapse nav navbar-nav"><li>
                                    <a href="http://www.winchesterstar.com/site/access_weekly.html"  target="_blank" rel="noopener" class="nav-link tnt-section-access-weekly">Access Weekly</a>
                                </li><li>
                                    <a href="/access/magazine/"  class="nav-link tnt-section-access-magazine">Access Magazine</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="https://www.google.com/maps/d/edit?mid=1zOCBS9ENV7CwUCbfVdLdHU6eB2yYzRp6&amp;ll=39.0310771276524%2C-78.2754971&amp;z=15"  target="_blank" rel="noopener" class="nav-link tnt-section-yard-sales-open-houses">Yard Sales & Open Houses</a>
                        </div>
                    </div></div></div></div>
                
                <div id="tncms-region-nav-mobile-nav-left-below" class="tncms-region-nav"></div>
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    

    

    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li>
                <a class="nav-link  tnt-section-about-us"  href="http://issuu.com/winchesterstar/docs/star120years/1"  target="_blank" rel="noopener">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/staff.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-subscriber-services"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    
                        <span class="fas tnt-caret-1"></span>
                    <span class="nav-label">Subscriber Services</span>
                </a><ul id="topbar-col-one-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-vacation-hold"  href="https://classadz.vdata.com/Legacy/WinchesterStar/Circulation/Subscriber/Vacation/Create"  target="_blank" rel="noopener">
                    <span class="nav-label">Vacation Hold</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscribe"  href="https://classadz.vdata.com/Legacy/WinchesterStar/Circulation/Subscriber/Default"  target="_blank" rel="noopener">
                    <span class="nav-label">Subscribe</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-digital-replica"  href="http://winchesterstar.va.newsmemory.com"  target="_blank" rel="noopener">
                    <span class="nav-label">Digital Replica</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-460786" class="tncms-block"><div id="user-controls-460786" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.winchesterstar.com/users/signup/?referer_url=https%3A%2F%2Fwww.winchesterstar.com%2Fobituaries%2Fallen-d-barr-jr%2Farticle_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.winchesterstar.com/users/login/?referer_url=https%3A%2F%2Fwww.winchesterstar.com%2Fobituaries%2Fallen-d-barr-jr%2Farticle_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.winchesterstar.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-460786').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.winchesterstar.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.winchesterstar.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.winchesterstar.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-460786').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.winchesterstar.com/users/logout/" id="user-logout-form-460786"><input type="hidden" name="referer_url" value="https://www.winchesterstar.com/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-512166" class="tncms-block float-button-right"><section id="block-512166" class="block emphasis-h3   " ><article class="card promo media"><div class="media-body"><p>DON’T LOG-IN YET! Read this Sign-Up Information first</p><a href="/site/sign_up_information.html" target="_blank" rel="noopener">
                <button type="button" class="btn btn-primary  ">Click</button>
            </a></div>
</article></section></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-460763" class="tncms-block"><section id="block-460763" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/b2cf80e8-654e-11e6-bd73-8738e9f8acb0.png?resize=200%2C29 200w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/b2cf80e8-654e-11e6-bd73-8738e9f8acb0.png?resize=300%2C44 300w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/b2cf80e8-654e-11e6-bd73-8738e9f8acb0.png?resize=400%2C58 400w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/b2cf80e8-654e-11e6-bd73-8738e9f8acb0.png?resize=540%2C79 540w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/b2cf80e8-654e-11e6-bd73-8738e9f8acb0.png?resize=750%2C109 750w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/b2cf80e8-654e-11e6-bd73-8738e9f8acb0.png 1200w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-460770" class="tncms-block"><section id="block-460770" class="block emphasis-h3   " >
        <div class="card-panel panel">
            <div class="panel-body">
    
    <div class="clearfix"></div>
    <div id="search-form-460770" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-460770" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal ">
        <input id="site-search-460770-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-460770-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    
            </div>
        </div>
    </section> 

<script>
    $('#site-search-460770-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-460770').submit();
        return false;
    });

    $('#site-search-460770').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-460770 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-460770 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-460770-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-460789" class="tncms-block clearfix padding-bottom"><div id="weather-460789" class="weather-current size-medium pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=22601" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-night-cloudy"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">49&deg;</span>
                    
                        <span class="cond">Cloudy <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="22601"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-460789 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Winchester, VA
                                
                                 <small>(22601)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Areas of fog. Low 44F. Winds light and variable..</p>
                            <h5>Tonight</h5>
                            <p>Areas of fog. Low 44F. Winds light and variable.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: February 25, 2020 @ 6:17 pm</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=22601"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" visible-sm visible-xs navbar-toggle pull-left" data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            
                        </button>
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-460764" class="tncms-block"><section id="block-460764" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/97bdb2ba-948e-11e6-b142-df02be2395fc.png?resize=200%2C28 200w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/97bdb2ba-948e-11e6-b142-df02be2395fc.png?resize=300%2C42 300w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/97bdb2ba-948e-11e6-b142-df02be2395fc.png?resize=400%2C57 400w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/97bdb2ba-948e-11e6-b142-df02be2395fc.png?resize=540%2C76 540w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/97bdb2ba-948e-11e6-b142-df02be2395fc.png?resize=750%2C106 750w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/97bdb2ba-948e-11e6-b142-df02be2395fc.png 1200w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-460773" class="tncms-block social-nav"><div class="follow-links-460773 pull-right">
    
    <section id="block-460773" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="http://www.facebook.com/pages/The-Winchester-Star/195641831897" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/intent/user?screen_name=WinStarVa" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.winchesterstar.com",
  "sameAs" : ["http://www.facebook.com/pages/The-Winchester-Star/195641831897","http://twitter.com/intent/user?screen_name=WinStarVa"]
}
</script>
<div class="clearfix"></div></div></div>
                                <div id="tncms-region-nav-main-nav-right-nav" class="tncms-region-nav"><ul id="main-nav-right-nav_menu" class="nav navbar-nav"></ul></div>
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news/" >
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-winchester"  href="/news/winchester/" >
                    <span class="nav-label">Winchester</span>
                </a></li><li>
                <a class="nav-link  tnt-section-frederick-county"  href="/news/frederick_county/" >
                    <span class="nav-label">Frederick County</span>
                </a></li><li>
                <a class="nav-link  tnt-section-clarke-county"  href="/news/clarke_county/" >
                    <span class="nav-label">Clarke County</span>
                </a></li><li>
                <a class="nav-link  tnt-section-ap-national"  href="/wire/national/" >
                    <span class="nav-label">AP National</span>
                </a></li><li>
                <a class="nav-link  tnt-section-ap-state-region"  href="/wire/state_region/" >
                    <span class="nav-label">AP State Region</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-opinions"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinions/" >
                    <span class="nav-label">Opinions</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-our-view"  href="/opinions/our_view/" >
                    <span class="nav-label">Our View</span>
                </a></li><li>
                <a class="nav-link  tnt-section-open-forums"  href="/opinions/open_forums/" >
                    <span class="nav-label">Open Forums</span>
                </a></li><li>
                <a class="nav-link  tnt-section-letters"  href="/opinions/letters/" >
                    <span class="nav-label">Letters</span>
                </a></li><li>
                <a class="nav-link  tnt-section-political-columns"  href="/opinions/columns/" >
                    <span class="nav-label">Political Columns</span>
                </a></li><li>
                <a class="nav-link  tnt-section-cartoons"  href="/opinions/cartoons/" >
                    <span class="nav-label">Cartoons</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-local-columns"  data-toggle="dropdown" data-target="#" data-nested="menu"    >
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">Local Columns</span>
                </a><ul id="main-nav_menu-child-3-child-6" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-chip-shots"  href="/columns/chip_shots/" >
                    <span class="nav-label">Chip Shots</span>
                </a></li><li>
                <a class="nav-link  tnt-section-connections"  href="/columns/connections/" >
                    <span class="nav-label">Connections</span>
                </a></li><li>
                <a class="nav-link  tnt-section-valley-pike"  href="/columns/valley_pike/" >
                    <span class="nav-label">Valley Pike</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-submit-an-opinion"  data-toggle="dropdown" data-target="#" data-nested="menu"    >
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">Submit an Opinion</span>
                </a><ul id="main-nav_menu-child-3-child-7" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-submit-an-open-forum"  href="https://www.winchesterstar.com/site/forms/online_services/open_forum/"  target="_blank" rel="noopener">
                    <span class="nav-label">Submit an Open Forum</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-a-letter-to-the-editor"  href="https://www.winchesterstar.com/site/forms/online_services/letter_editor/"  target="_blank" rel="noopener">
                    <span class="nav-label">Submit a Letter to the Editor</span>
                </a></li></ul></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-high-school"  href="/sports/high_school" >
                    <span class="nav-label">High School</span>
                </a></li><li>
                <a class="nav-link  tnt-section-spotlights"  href="/sports/spotlights/" >
                    <span class="nav-label">Spotlights</span>
                </a></li><li>
                <a class="nav-link  tnt-section-college"  href="/sports/college" >
                    <span class="nav-label">College</span>
                </a></li><li>
                <a class="nav-link  tnt-section-ap-sports"  href="/wire/sports/" >
                    <span class="nav-label">AP Sports</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries/" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-life"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/lifestyles/" >
                    <span class="nav-label">Life</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-features"  href="/lifestyles/features/" >
                    <span class="nav-label">Features</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weekend"  href="/lifestyles/weekend/" >
                    <span class="nav-label">Weekend</span>
                </a></li><li>
                <a class="nav-link  tnt-section-food"  href="/lifestyles/food/" >
                    <span class="nav-label">Food</span>
                </a></li><li>
                <a class="nav-link  tnt-section-out-of-the-past"  href="/lifestyles/out_of_the_past/" >
                    <span class="nav-label">Out Of The Past</span>
                </a></li><li>
                <a class="nav-link  tnt-section-bulletin-board"  href="/lifestyles/bulletin_board/" >
                    <span class="nav-label">Bulletin Board</span>
                </a></li><li>
                <a class="nav-link  tnt-section-ap-entertainment"  href="/wire/entertainment/" >
                    <span class="nav-label">AP Entertainment</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-advertise-with-us"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Advertise With Us</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-how-to-advertise-with-us"  href="https://www.winchesterstar.com/site/forms/online_services/how_to_advertise_with_us/"  target="_blank" rel="noopener">
                    <span class="nav-label">How to Advertise With Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-create-a-classified-ad"  href=" https://classadz.vdata.com/WinchesterStar/Advertising/Advertiser" >
                    <span class="nav-label">Create a Classified Ad</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/classifieds/" >
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-public-notices-and-legal-ads"  href="/notices/" >
                    <span class="nav-label">Public Notices and Legal Ads</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-jobs"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="http://winchestervirginiajobs.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Jobs</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-weekly-employment-display-ads"  href="/employment/" >
                    <span class="nav-label">Weekly Employment Display Ads</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-events"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Events</span>
                </a><ul id="main-nav_menu-child-10" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-see-the-calendar-page"  href="/calendar/" >
                    <span class="nav-label">See the Calendar Page</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-an-event"  href="https://www.winchesterstar.com/users/admin/calendar/event/"  target="_blank" rel="noopener">
                    <span class="nav-label">Submit an Event</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-photos"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Photos</span>
                </a><ul id="main-nav_menu-child-11" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-photo-galleries"  href="/photo/" >
                    <span class="nav-label">Photo Galleries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-order-photos"  href="http://winchesterstar.mycapture.com/mycapture/index.asp"  target="_blank" rel="noopener">
                    <span class="nav-label">Order Photos</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-access"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Access</span>
                </a><ul id="main-nav_menu-child-12" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-access-weekly"  href="http://www.winchesterstar.com/site/access_weekly.html"  target="_blank" rel="noopener">
                    <span class="nav-label">Access Weekly</span>
                </a></li><li>
                <a class="nav-link  tnt-section-access-magazine"  href="/access/magazine/" >
                    <span class="nav-label">Access Magazine</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-yard-sales-open-houses"  href="https://www.google.com/maps/d/edit?mid=1zOCBS9ENV7CwUCbfVdLdHU6eB2yYzRp6&amp;ll=39.0310771276524%2C-78.2754971&amp;z=15"  target="_blank" rel="noopener">
                    <span class="nav-label">Yard Sales & Open Houses</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
                
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-695291" class="tncms-block"><div id="WSWV_Top_728x90" style="text-align:center; margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('WSWV_Top_728x90'); });
</script>
</div></div><div id="tncms-block-497896" class="tncms-block hidden-xs hidden-sm hidden-md"><script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.winchesterstar.com",
  secureDomain: "www.winchesterstar.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div id="blox-ad-position-pencil1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"pencil","slot":"1","fold":"","width":"960","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/winchesterstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><div id="modal-image-582733aa-8259-59c3-bd4c-b64a441f873f" class="modal fullscreen in modal-image image-default modal-582733aa-8259-59c3-bd4c-b64a441f873f" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-vertical">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/5/82/582733aa-8259-59c3-bd4c-b64a441f873f/5e5426566a89f.image.jpg"
                    srcset="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/5/82/582733aa-8259-59c3-bd4c-b64a441f873f/5e5426566a89f.image.jpg?resize=200%2C255 200w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/5/82/582733aa-8259-59c3-bd4c-b64a441f873f/5e5426566a89f.image.jpg?resize=300%2C382 300w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/5/82/582733aa-8259-59c3-bd4c-b64a441f873f/5e5426566a89f.image.jpg?resize=314%2C400 400w"
                    sizes="100vw"
                    width="314"
                    height="400"
                    alt="Allen D. Barr, Jr."
                    class="img-responsive true-size" />
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-582733aa-8259-59c3-bd4c-b64a441f873f" data-target=".caption-inner-modal-image-582733aa-8259-59c3-bd4c-b64a441f873f">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-582733aa-8259-59c3-bd4c-b64a441f873f collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.winchesterstar.com%2Fallen-d-barr-jr%2Fimage_582733aa-8259-59c3-bd4c-b64a441f873f.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/allen-d-barr-jr/image_582733aa-8259-59c3-bd4c-b64a441f873f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"582733aa-8259-59c3-bd4c-b64a441f873f"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Allen%20D.%20Barr%2C%20Jr.&via=WinStarVa&url=https%3A%2F%2Fwww.winchesterstar.com%2Fallen-d-barr-jr%2Fimage_582733aa-8259-59c3-bd4c-b64a441f873f.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/allen-d-barr-jr/image_582733aa-8259-59c3-bd4c-b64a441f873f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"582733aa-8259-59c3-bd4c-b64a441f873f"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.winchesterstar.com/allen-d-barr-jr/image_582733aa-8259-59c3-bd4c-b64a441f873f.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/allen-d-barr-jr/image_582733aa-8259-59c3-bd4c-b64a441f873f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"582733aa-8259-59c3-bd4c-b64a441f873f"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.winchesterstar.com/tncms/asset/editorial/582733aa-8259-59c3-bd4c-b64a441f873f" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"582733aa-8259-59c3-bd4c-b64a441f873f"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Winchester%20Star%5D%20Allen%20D.%20Barr%2C%20Jr.&body=https%3A%2F%2Fwww.winchesterstar.com%2Fallen-d-barr-jr%2Fimage_582733aa-8259-59c3-bd4c-b64a441f873f.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"582733aa-8259-59c3-bd4c-b64a441f873f"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/allen-d-barr-jr/image_582733aa-8259-59c3-bd4c-b64a441f873f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"582733aa-8259-59c3-bd4c-b64a441f873f"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-582733aa-8259-59c3-bd4c-b64a441f873f-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="582733aa-8259-59c3-bd4c-b64a441f873f" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="582733aa-8259-59c3-bd4c-b64a441f873f" class="save-list-582733aa-8259-59c3-bd4c-b64a441f873f-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="582733aa-8259-59c3-bd4c-b64a441f873f" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-582733aa-8259-59c3-bd4c-b64a441f873f img { max-height: 400px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-5570194b-ccc3-541a-a6a8-cd4628f9e0e0" class="asset article-default"  data-url="https://www.winchesterstar.com/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/5/82/582733aa-8259-59c3-bd4c-b64a441f873f/5e5426566a89f.image.jpg?resize=314%2C400">
            <meta itemprop="width" content="314">
            <meta itemprop="height" content="400">
        </div>
        <meta itemprop="name" content="winchesterstar.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.winchesterstar.com/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html" />
    <style>
                .asset-paging .direction {
                    color: #AAA;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":true,"nextUrl":"https:\/\/www.winchesterstar.com\/tncms\/search\/mlt\/?origin=5570194b-ccc3-541a-a6a8-cd4628f9e0e0&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-5570194b-ccc3-541a-a6a8-cd4628f9e0e0" class="asset-paging">
                <div id="paging-prev-5570194b-ccc3-541a-a6a8-cd4628f9e0e0" class="paging-link prev offset"></div>
                <div id="paging-next-5570194b-ccc3-541a-a6a8-cd4628f9e0e0" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Allen D. Barr, Jr.
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2020-02-25T00:00:00-05:00" class="tnt-date asset-date text-muted">
            Feb 25, 2020
        </time>
    </li>
            <li class="hidden-print">
        <time datetime="2020-02-25T00:00:00-05:00" class="tnt-date asset-date text-muted">18 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html#comments" class="cm" title="0 entries"><span class="fas tnt-book"></span> <span class="count">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-02-25T00:00:00-05:00">
    <meta itemprop="datePublished" content="2020-02-25T00:00:00-05:00">
    <meta itemprop="dateModified" content="2020-02-25T00:00:00-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.winchesterstar.com%2Fobituaries%2Fallen-d-barr-jr%2Farticle_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Allen%20D.%20Barr%2C%20Jr.&via=WinStarVa&url=https%3A%2F%2Fwww.winchesterstar.com%2Fobituaries%2Fallen-d-barr-jr%2Farticle_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.winchesterstar.com/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.winchesterstar.com/tncms/asset/editorial/5570194b-ccc3-541a-a6a8-cd4628f9e0e0" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Winchester%20Star%5D%20Allen%20D.%20Barr%2C%20Jr.&body=https%3A%2F%2Fwww.winchesterstar.com%2Fobituaries%2Fallen-d-barr-jr%2Farticle_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-vertical hover-expand"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-582733aa-8259-59c3-bd4c-b64a441f873f" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-582733aa-8259-59c3-bd4c-b64a441f873f" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="314">
            <meta itemprop="height" content="400">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/5/82/582733aa-8259-59c3-bd4c-b64a441f873f/5e5426566a89f.image.jpg">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/5/82/582733aa-8259-59c3-bd4c-b64a441f873f/5e5426566a89f.image.jpg">
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/5/82/582733aa-8259-59c3-bd4c-b64a441f873f/5e5426566a89f.image.jpg"
                    srcset="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/5/82/582733aa-8259-59c3-bd4c-b64a441f873f/5e5426566a89f.image.jpg?resize=200%2C255 200w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/5/82/582733aa-8259-59c3-bd4c-b64a441f873f/5e5426566a89f.image.jpg?resize=300%2C382 300w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/5/82/582733aa-8259-59c3-bd4c-b64a441f873f/5e5426566a89f.image.jpg?resize=314%2C400 400w"
                    sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), 100vw"
                    width="314"
                    height="400"
                    alt="Allen D. Barr, Jr."
                    class="img-responsive  letterbox tnt-restrict-img-582733aa-8259-59c3-bd4c-b64a441f873f" />
            </div><style>
                .tnt-restrict-img-582733aa-8259-59c3-bd4c-b64a441f873f {
                    max-width: 314px;
                }
            </style>
                
            </div>
            
                
                
            
        </figure></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="5570194b-ccc3-541a-a6a8-cd4628f9e0e0">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.winchesterstar.com%2Fobituaries%2Fallen-d-barr-jr%2Farticle_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Allen%20D.%20Barr%2C%20Jr.&via=WinStarVa&url=https%3A%2F%2Fwww.winchesterstar.com%2Fobituaries%2Fallen-d-barr-jr%2Farticle_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.winchesterstar.com/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.winchesterstar.com/tncms/asset/editorial/5570194b-ccc3-541a-a6a8-cd4628f9e0e0" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Winchester%20Star%5D%20Allen%20D.%20Barr%2C%20Jr.&body=https%3A%2F%2Fwww.winchesterstar.com%2Fobituaries%2Fallen-d-barr-jr%2Farticle_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-5570194b-ccc3-541a-a6a8-cd4628f9e0e0-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="5570194b-ccc3-541a-a6a8-cd4628f9e0e0" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="5570194b-ccc3-541a-a6a8-cd4628f9e0e0" class="save-list-5570194b-ccc3-541a-a6a8-cd4628f9e0e0-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="5570194b-ccc3-541a-a6a8-cd4628f9e0e0" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>Allen D. Barr, Jr., 53, of Frederick County, Virginia, passed away Saturday, February 22, 2020, at his home surrounded by his family.</p><p>Mr. Barr was born in 1966 in Winchester, Virginia, son of the late Dorothy L. and Allen D. Barr, Sr. He was employed at NRADC as a Corrections Officer, achieving the rank of Captain, having served for 28 years. Mr. Barr was a member of the Winchester Moose Lodge. He enjoyed hunting, hiking, and being in the outdoors. He especially loved spending time with his children.</p><p>He married Patricia N. Fraber on August 1, 1992, in Winchester, Virginia.</p><p>Surviving with his wife, is his daughter, Cierra Barr and son, Cody Barr.</p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>The family will receive friends from 6 p.m. to 8 p.m. on Tuesday at Omps Funeral Home, Amherst Chapel. Per Allen’s request please dress in comfortable clothing for the visitation...no suits or ties. Interment will be private.</p><p>In lieu of flowers, memorial contributions in memory of Allen may be made to St. Jude Children’s Research Hospital, P.O. Box 1000, Dept. 142, Memphis, Tennessee 38148.</p><p>Please view obituary and tribute wall at <a href="http://www.ompsfuneralhome.com">www.ompsfuneralhome.com</a></p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.winchesterstar.com%2Fobituaries%2Fallen-d-barr-jr%2Farticle_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Allen%20D.%20Barr%2C%20Jr.&via=WinStarVa&url=https%3A%2F%2Fwww.winchesterstar.com%2Fobituaries%2Fallen-d-barr-jr%2Farticle_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.winchesterstar.com/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.winchesterstar.com/tncms/asset/editorial/5570194b-ccc3-541a-a6a8-cd4628f9e0e0" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BThe%20Winchester%20Star%5D%20Allen%20D.%20Barr%2C%20Jr.&body=https%3A%2F%2Fwww.winchesterstar.com%2Fobituaries%2Fallen-d-barr-jr%2Farticle_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5570194b-ccc3-541a-a6a8-cd4628f9e0e0"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-5570194b-ccc3-541a-a6a8-cd4628f9e0e0-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="5570194b-ccc3-541a-a6a8-cd4628f9e0e0" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="5570194b-ccc3-541a-a6a8-cd4628f9e0e0" class="save-list-5570194b-ccc3-541a-a6a8-cd4628f9e0e0-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="5570194b-ccc3-541a-a6a8-cd4628f9e0e0" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Add an entry<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="5570194b-ccc3-541a-a6a8-cd4628f9e0e0" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Adding">Add entry</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your entry has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch the guestbook.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this guestbook.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="5570194b-ccc3-541a-a6a8-cd4628f9e0e0" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone signs the guestbook.
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this guestbook will end.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-book"></span> (0) entries 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom desc usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Sign the guestbook.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.winchesterstar.com/users/login/?referer_url=https%3A%2F%2Fwww.winchesterstar.com%2Fobituaries%2Fallen-d-barr-jr%2Farticle_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Add an entry</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch the guestbook.</span>
                                    <span class="unsubscribe">Stop watching this guestbook.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-460710" class="tncms-block visible-lg visible-md"><section id="block-460710" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-460710 ">
        <div class="block-title-inner">
            <h4>
                
                Latest News
                
            </h4>
        </div>
    </div></div>
    <div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><ul class="card headline-list bullet-square border border-dashed"><li class="">
            <span class="tnt-headline ">
        
             <a href="/associated_press/washington/sanders-makes-bold-play-to-win-primary-on-warren-s/article_f0bec98b-56fc-53a6-a14f-a4e7360a18a8.html" class="tnt-asset-link">
        

        
            Sanders makes bold play to win primary on Warren’s home turf</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/associated_press/national_sports/ers-simmons-out-at-least-more-weeks-with-back-injury/article_5f8a99db-1864-5142-95d5-e80ab6e86a02.html" class="tnt-asset-link">
        

        
            76ers' Simmons out at least 2 more weeks with back injury</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/associated_press/washington/can-bernie-be-stopped-some-democratic-donors-are-trying/article_ac892847-0fdb-5a30-b5bb-676110e63f69.html" class="tnt-asset-link">
        

        
            Can Bernie be stopped? Some Democratic donors are trying</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/associated_press/national_sports/hot-pockets-heir-gets-months-in-prison-for-college-scam/article_30ddad7b-b298-5264-b476-ec8baa5ec6b5.html" class="tnt-asset-link">
        

        
            Hot Pockets heir gets 5 months in prison for college scam</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/associated_press/national_sports/english-woman-wins-annual-pancake-race-with-kansas/article_7c1b8dd8-3936-53d0-ac4e-9bf6d2abbc21.html" class="tnt-asset-link">
        

        
            English woman wins annual pancake race with Kansas</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/associated_press/entertainment/criminal-minds-fresh-off-the-boat-end-on-ratings-high/article_6f83a8ec-a867-58a6-be71-9cb097384681.html" class="tnt-asset-link">
        

        
            'Criminal Minds,' 'Fresh Off the Boat' end on ratings high</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/associated_press/entertainment/disney-ceo-bob-iger-steps-down-bob-chapek-named-new/article_0db5481b-ba77-5e46-b4a2-e386f237bb7b.html" class="tnt-asset-link">
        

        
            Disney CEO Bob Iger steps down, Bob Chapek named new head</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/associated_press/washington/senate-gop-again-thwarted-on-bills-to-restrict-abortion/article_66e72ae7-4e69-51af-b423-b437f956a269.html" class="tnt-asset-link">
        

        
            Senate GOP again thwarted on bills to restrict abortion</a></span>
        </li></ul></div>
        </div></div></section></div><div id="tncms-block-695290" class="tncms-block"><div id="WSWV_Right_300x600" style="text-align:center; margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('WSWV_Right_300x600'); });
</script>
</div></div><div id="tncms-block-633405" class="tncms-block"><section id="block-633405" class="block emphasis-h4   " ><div class=" ">
        
            
            <article id="card-showcase-394e63e7-fa05-55bc-a966-08d730603cff" class="clearfix card showcase position-0 odd  tnt-section-lfcc-workforce">
            <div class="card-container"><div class="card-body"><div class="card-labels">
            
                <div class="card-label-section text-muted">
                    Lfcc Workforce
                </div>
            
            
        </div><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="https://lfccworkforce.com/commercial-truck-driver-cdl-b-fast-track-career-training-program/" class="tnt-asset-link" target="_blank" rel="noopener">
        

        
            Commercial Truck Driver CDL-B Fast-Track Career Training Program</a></h4></div><div class="card-meta">
            <ul class="list-inline">
                        <li class="card-byline text-muted"><span  class="tnt-byline">Guy Curtis</span></li></ul>
        </div>
                    </div>
            </div>
            <div class="clearfix"></div>
        </article>
            
        
    </div></section></div><div id="tncms-block-460766" class="tncms-block hidden-sm hidden-xs"><section id="block-460766" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-460766 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-460766" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-460766" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
        
        
        
            <li >
                <a href="#commented-460766" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-460766" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/winchester_star/final-services-in-first-united-methodist-church-s-longtime-downtown/article_cfcd1961-ba0c-580b-9333-b02f38529fc9.html">Final services in First United Methodist Church's longtime downtown location will be Sunday</a></li><li><a href="/winchester_star/developer-eyes-town-homes-retailers-for-former-seafood-restaurant-site/article_2d34d8d9-7d4d-5a8a-89bd-fba4d16ece8e.html">Developer eyes town homes, retailers for former 220 Seafood Restaurant site</a></li><li><a href="/winchester_star/drug-dealer-gets-years/article_56be41ad-d787-59e6-a15f-d04e610a2438.html">Drug dealer gets 2 years</a></li><li><a href="/obituaries/allen-d-barr-jr/article_5570194b-ccc3-541a-a6a8-cd4628f9e0e0.html">Allen D. Barr, Jr.</a></li><li><a href="/winchester_star/alert-employees-quick-response-from-firefighters-helped-contain-warehouse-blaze/article_2c151eb6-3cd2-5b96-ba74-49bdce153644.html">Alert employees, quick response from firefighters helped contain warehouse blaze</a></li><li><a href="/obituaries/dale-irwin-foreman-phd/article_6aef7b09-c109-5d60-9caa-e7fa09c499d4.html">Dale Irwin Foreman, PhD</a></li><li><a href="/obituaries/eva-n-baker/article_e84d4a2c-6620-5a4e-a2c8-c3ac0b664990.html">Eva N. Baker</a></li><li><a href="/winchester_star/church-opens-happy-valley-daycare/article_2dc09de0-8046-52cb-bc7b-222a61c7758f.html">Church opens Happy Valley Daycare</a></li><li><a href="/obituaries/roy-paco-mitchell/article_b2288dea-15c8-5e1e-9577-469162cae434.html">Roy "Paco" Mitchell</a></li><li><a href="/obituaries/death-notices-for-feb/article_e54a320c-1892-59d8-95eb-ea6ad97afa44.html">Death notices for Feb. 25</a></li></ul></div>
        
        
            <div id="images-460766" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/winchester_star/cartoon-poll/image_4166d948-9c28-548d-a874-501316f28f61.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Cartoon: Poll"
                            class="img-responsive lazyload full"
                            width="1312"
                            height="1312"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/4/16/4166d948-9c28-548d-a874-501316f28f61/5e5417d063949.image.jpg?crop=1312%2C1312%2C133%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/winchester_star/political-cartoon/image_157f288b-5eb5-529f-8177-a0b24e51acd0.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Political cartoon"
                            class="img-responsive lazyload full"
                            width="1194"
                            height="1194"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/1/57/157f288b-5eb5-529f-8177-a0b24e51acd0/5e52fcae8c47a.image.jpg?crop=1194%2C1194%2C271%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/tony-kim/image_79b1e0cc-919f-5438-94c1-cb24bc5ee79d.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Tony Kim"
                            class="img-responsive lazyload full"
                            width="428"
                            height="428"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/7/9b/79b1e0cc-919f-5438-94c1-cb24bc5ee79d/5e530dcaacc3f.image.jpg?crop=428%2C428%2C0%2C76&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
            </div>
            
        </figure></li>
                        </ul></div>
        
        
        
        
        
            <div id="commented-460766" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><ul class="tab-content-list bullet-disc "><li><a href="/winchester_star/open-forum-clint-eastwood-didn-t-make-his-day/article_2a0a57aa-b460-5186-8a96-a619abddc98f.html">Open Forum: Clint Eastwood didn't make his day</a> (11)</li><li><a href="/winchester_star/developer-eyes-town-homes-retailers-for-former-seafood-restaurant-site/article_2d34d8d9-7d4d-5a8a-89bd-fba4d16ece8e.html">Developer eyes town homes, retailers for former 220 Seafood Restaurant site</a> (6)</li><li><a href="/winchester_star/founder-of-tony-s-shoe-repair-succumbs-to-cancer/article_609d4112-b2da-5046-8285-054932b0a948.html">Founder of Tony's Shoe Repair succumbs to cancer</a> (6)</li><li><a href="/winchester_star/final-services-in-first-united-methodist-church-s-longtime-downtown/article_cfcd1961-ba0c-580b-9333-b02f38529fc9.html">Final services in First United Methodist Church's longtime downtown location will be Sunday</a> (6)</li><li><a href="/winchester_star/open-forum-a-sword-that-cuts-both-ways/article_bd76d0eb-441f-579c-bfc4-0d38dff67575.html">Open Forum: A sword that cuts both ways</a> (5)</li><li><a href="/winchester_star/open-forum-vote-for-biden-on-super-tuesday/article_6ae02a33-a825-5a69-ae91-cbe7194c7d89.html">Open Forum: Vote for Biden on Super Tuesday</a> (4)</li><li><a href="/winchester_star/trailer-unveiled-for-potential-rescue-ride-documentary/article_63fd5dc2-8b16-5249-8ff0-9d5c691fb256.html">Trailer unveiled for potential Rescue Ride documentary</a> (3)</li><li><a href="/winchester_star/letter-to-the-editor-article-prompted-some-history-sleuthing/article_71d860a1-c408-50af-965d-a5e18787b1c2.html">Letter to the editor: Article prompted some history sleuthing</a> (3)</li><li><a href="/winchester_star/open-forum-williams-is-spewing-misinformation/article_ea03a84d-e5cb-5055-8421-35ebc4382b84.html">Open Forum: Williams is spewing misinformation</a> (3)</li><li><a href="/associated_press/washington/sanders-would-use-wealth-tax-for-universal-child-care-pre/article_2d8d9a17-44cb-5776-92df-7b0152e666a8.html">Sanders would use wealth tax for universal child care, pre-K</a> (1)</li></ul></div>
        
    </div>
</div></section></div><div id="tncms-block-497877" class="tncms-block hidden-xs hidden-sm hidden-md">
        <div id="blox-ad-position-block-big-ad-side-rail-top-extra1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-big-ad-side-rail-top-extra","slot":"1","fold":"above","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/winchesterstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-695283" class="tncms-block"><div id="WSWV_Middle_300x250" style="text-align:center; margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('WSWV_Middle_300x250'); });
</script>
</div></div><div id="tncms-block-695285" class="tncms-block"><div id="WSWV_Middle2_300x250" style="text-align:center; margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('WSWV_Middle2_300x250'); });
</script>
</div></div></div>  
                        <div class="row two-banner">
				<div class="col-md-6 text-center"><div id="tncms-region-side-banner-one" class="tncms-region "><div id="tncms-block-695293" class="tncms-block"><div id="WIN_Tile_1" style="text-align:center; margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('WIN_Tile_1'); });
</script>
</div></div></div></div>
				<div class="col-md-6 text-center"><div id="tncms-region-side-banner-two" class="tncms-region "><div id="tncms-block-695294" class="tncms-block"><div id="WIN_Tile_2" style="text-align:center; margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('WIN_Tile_2'); });
</script>
</div></div></div></div>
			</div> 
                        <div class="row two-banner">
				<div class="col-md-6 text-center"><div id="tncms-region-side-banner-three" class="tncms-region "><div id="tncms-block-695295" class="tncms-block"><div id="WIN_Tile_3" style="text-align:center; margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('WIN_Tile_3'); });
</script>
</div></div><div id="tncms-block-695300" class="tncms-block"><div id="WIN_Tile_7" style="text-align:center; margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('WIN_Tile_7'); });
</script>
</div></div></div></div>
				<div class="col-md-6 text-center"><div id="tncms-region-side-banner-four" class="tncms-region "><div id="tncms-block-695296" class="tncms-block"><div id="WIN_Tile_4" style="text-align:center; margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('WIN_Tile_4'); });
</script>
</div></div><div id="tncms-block-695299" class="tncms-block"><div id="WIN_Tile_6" style="text-align:center; margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('WIN_Tile_6'); });
</script>
</div></div><div id="tncms-block-695301" class="tncms-block"><div id="WIN_Tile_8" style="text-align:center; margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('WIN_Tile_8'); });
</script>
</div></div></div></div>
			</div> 
                        
<div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-497871" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-right-rectangle-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-right-rectangle-bottom","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/winchesterstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-551576" class="tncms-block visible-xs"><section id="block-551576" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-551576 ">
        <div class="block-title-inner">
            <h3>
                
                Entertainment
                
            </h3>
        </div>
    </div></div><div class="card-grid   card-img-md card-bg-color card-compact">
        
        
            <div class=" row equal equal-wrap">
        
        <div class=" col-sm-3 ">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-551576-9b1a077d-e27e-5961-8e7e-aa39dd5be1b4" class="clearfix card summary has-image image-top inherit  tnt-section-winchester-star">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-9b1a077d-e27e-5961-8e7e-aa39dd5be1b4 media-preview image-asset" data-aspect="1:1"><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="/winchester_star/remembering-their-service/image_9b1a077d-e27e-5961-8e7e-aa39dd5be1b4.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Remembering their service"
                            class="img-responsive lazyload full"
                            width="1123"
                            height="1123"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/9/b1/9b1a077d-e27e-5961-8e7e-aa39dd5be1b4/5ce8a0774d862.image.jpg?crop=1123%2C1123%2C361%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/9/b1/9b1a077d-e27e-5961-8e7e-aa39dd5be1b4/5ce8a0774d862.image.jpg?crop=1123%2C1123%2C361%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/9/b1/9b1a077d-e27e-5961-8e7e-aa39dd5be1b4/5ce8a0774d862.image.jpg?crop=1123%2C1123%2C361%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/9/b1/9b1a077d-e27e-5961-8e7e-aa39dd5be1b4/5ce8a0774d862.image.jpg?crop=1123%2C1123%2C361%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/9/b1/9b1a077d-e27e-5961-8e7e-aa39dd5be1b4/5ce8a0774d862.image.jpg?crop=1123%2C1123%2C361%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/9/b1/9b1a077d-e27e-5961-8e7e-aa39dd5be1b4/5ce8a0774d862.image.jpg?crop=1123%2C1123%2C361%2C0&resize=1123%2C1123&order=crop%2Cresize 1200w" />
                </a>
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/winchester_star/remembering-their-service/image_9b1a077d-e27e-5961-8e7e-aa39dd5be1b4.html" class="tnt-asset-link">
        

        
            Remembering their service</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-3 ">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-551576-783093a5-4716-5a88-9aa6-b3e9ca71aa85" class="clearfix card summary inherit  tnt-section-winchester-star">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/winchester_star/krampus-coming-to-winchester-tonight/article_783093a5-4716-5a88-9aa6-b3e9ca71aa85.html" class="tnt-asset-link">
        

        
            Krampus coming to Winchester tonight</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-3 ">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-551576-b7283731-aeca-590b-83fd-2181a415a6d8" class="clearfix card summary inherit  tnt-section-winchester-star">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/winchester_star/clarke-public-hearing-on-towers-slated-this-morning/article_b7283731-aeca-590b-83fd-2181a415a6d8.html" class="tnt-asset-link">
        

        
            Clarke public hearing on towers slated this morning</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-3 last-grid-item">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-551576-fa60e5da-236e-11e7-b4bf-63704f8b50c9" class="clearfix card summary has-image image-top inherit ">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-fa60e5da-236e-11e7-b4bf-63704f8b50c9 media-preview link-asset" data-aspect="1:1"><figure class="photo layout-square">
            <div class="image" 
                >
                
                    <a href="http://tvtv.us/va/winchester" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="TV Listings"
                            class="img-responsive lazyload full"
                            width="125"
                            height="125"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/assets/v3/editorial/f/a6/fa60e5da-236e-11e7-b4bf-63704f8b50c9/58f4c0927703e.preview.jpg?resize=125%2C125" />
                </a>
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="http://tvtv.us/va/winchester" class="tnt-asset-link">
        

        
            TV Listings</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
                    <div class="clearfix hidden-xs"></div>
                
            
            
        
        <div class="clearfix hidden-xs"></div>
        
        
        </div>
        </div></section></div><div id="tncms-block-695292" class="tncms-block"><div id="WSWV_Bottom_728x90" style="text-align:center; margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('WSWV_Bottom_728x90'); });
</script>
</div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"><div id="tncms-block-531912" class="tncms-block"><div id="ap_widget_container_c441d48ff5f2251dd4d5573dd719c068"></div>
<script src="http://digitalservices.ap.org/widget-content/c441d48ff5f2251dd4d5573dd719c068"></script></div></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
<!-- code here -->



<script>
$(document).ready(function(){
 $('#asset-content > div.row > div > div > div.asset-content.subscriber-premium > div.subscription-required > div > div > div > div > div.row.not-logged-in > div:nth-child(1) > a:contains("Sign Up")').attr("href","/users/signup/?referer_url=https://classadz.vdata.com/Legacy/WinchesterStar/Circulation/Subscriber");
/*$('#user-controls-413161 ul li:first-child a.user-control-link').attr("href","/subscribe");*/
$('#asset-content > div.row > div > div > div > div.subscription-required > div > div > div > div > div.row.logged-in > div > a').attr("href","https://classadz.vdata.com/Legacy/WinchesterStar/Circulation/Subscriber");
/*$('#user-controls ul li:first-child a.user-control-link').attr("href","https://dnronline-com.bloxcms-ny1.com/users/admin/");*/
$('#user-controls ul li:first-child a.user-control-link').attr("href","/users/admin/");
$('#user-main-menu-wrapper > div > div.col-md-9.col-md-push-3 > div:nth-child(5) > a:contains("Return to the home page")').attr("href","/");


});



</script>

                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-460751" class="tncms-block"><section id="block-460751" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-460751 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-news"  href="/news/" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-opinion"  href="/opinions/" >
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-lifestyles"  href="/lifestyles" >
                    <span class="nav-label">Lifestyles</span>
                </a></li><li>
                <a class="nav-link  tnt-section-wire"  href="/wire/" >
                    <span class="nav-label">Wire</span>
                </a></li><li>
                <a class="nav-link  tnt-section-events"  href="/calendar/" >
                    <span class="nav-label">Events</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-460752" class="tncms-block"><section id="block-460752" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-460752 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-about-us"  href="http://issuu.com/winchesterstar/docs/star120years/1"  target="_blank" rel="noopener">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-how-to-advertise-with-us"  href="https://www.winchesterstar.com/site/forms/online_services/how_to_advertise_with_us/"  target="_blank" rel="noopener">
                    <span class="nav-label">How to Advertise With Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-staff"  href="/site/staff.html" >
                    <span class="nav-label">Staff</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscribe"  href="https://classadz.vdata.com/Legacy/WinchesterStar/Circulation/Subscriber/Default"  target="_blank" rel="noopener">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscriber-services"  href="https://classadz.vdata.com/Legacy/WinchesterStar/Circulation/Subscriber"  target="_blank" rel="noopener">
                    <span class="nav-label">Subscriber Services</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submission-forms"  href="/site/forms/" >
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link  tnt-section-classifieds"  href="/classifieds/" >
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link  tnt-section-search"  href="/search/" >
                    <span class="nav-label">Search</span>
                </a></li><li>
                <a class="nav-link  tnt-section-questionscomments"  href="https://www.winchesterstar.com/site/forms/online_services/contact_us/"  target="_blank" rel="noopener">
                    <span class="nav-label">Questions/Comments</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-524247" class="tncms-block padding-bottom"><section id="block-524247" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/4ba90f80-d37e-11e6-8150-433dfc03e851.jpg?resize=200%2C30 200w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/4ba90f80-d37e-11e6-8150-433dfc03e851.jpg?resize=300%2C45 300w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/4ba90f80-d37e-11e6-8150-433dfc03e851.jpg?resize=400%2C60 400w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/4ba90f80-d37e-11e6-8150-433dfc03e851.jpg?resize=540%2C81 540w, https://bloximages.newyork1.vip.townnews.com/winchesterstar.com/content/tncms/custom/image/4ba90f80-d37e-11e6-8150-433dfc03e851.jpg 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div><div id="tncms-block-460757" class="tncms-block"><section id="block-460757" class="block emphasis-h4   " ><address>
    <strong>winchesterstar.com</strong><br>
    100 N. Loudoun StreetSuite 110<br>
    Winchester, VA 22601
    <br>
    
        <strong>Phone:</strong> 540-667-3200<br>
        <strong>Email:</strong> <a href="mailto:citydesk@winchesterstar.com">citydesk@winchesterstar.com</a><br>
    
</address></section></div><div id="tncms-block-460774" class="tncms-block padding-bottom"><div class="follow-links-460774 default">
    
    <section id="block-460774" class="block emphasis-h4   " ><ul class="list-inline">
        
            <li>
                <a href="http://www.facebook.com/pages/The-Winchester-Star/195641831897" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/intent/user?screen_name=WinStarVa" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.winchesterstar.com",
  "sameAs" : ["http://www.facebook.com/pages/The-Winchester-Star/195641831897","http://twitter.com/intent/user?screen_name=WinStarVa"]
}
</script>
<div class="clearfix"></div></div></div><div id="tncms-region-nav-footer-col-three-nav" class="tncms-region-nav"><ul id="footer-col-three-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-harrisonburg-daily-news-record"  href="/Byrd_Newspapers/Harrisonburg_Daily_News-Record" >
                    <span class="nav-label">Harrisonburg Daily News-Record</span>
                </a></li><li>
                <a class="nav-link  tnt-section-page-news-and-courier"  href="/Byrd_Newspapers/Page_News_and_Courier" >
                    <span class="nav-label">Page News and Courier</span>
                </a></li><li>
                <a class="nav-link  tnt-section-shenandoah-valley-herald"  href="/Byrd_Newspapers/Shenandoah_Valley_Herald" >
                    <span class="nav-label">Shenandoah Valley Herald</span>
                </a></li><li>
                <a class="nav-link  tnt-section-valley-banner"  href="/Byrd_Newspapers/Valley_Banner" >
                    <span class="nav-label">Valley Banner</span>
                </a></li><li>
                <a class="nav-link  tnt-section-warren-sentinel"  href="/Byrd_Newspapers/Warren_Sentinel" >
                    <span class="nav-label">Warren Sentinel</span>
                </a></li></ul></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
<!-- code here -->
<!-- #tntracking #607426-->



            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-460758" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-460758"><div class="col-md-7"><small>&copy; Copyright 2020 <a href="/">The Winchester Star</a>, 100 N. Loudoun StreetSuite 110 Winchester, VA</small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
$(function(){
    var compatible = true;
    var status = "";
    if(typeof(__tnt.advertisements)=="undefined"){
        compatible = false;
        status = "FAIL: object 0 undefined"
    }
    if(typeof(__tnt.ads)=="undefined"){
        compatible = false;
        status = "FAIL: object 1 undefined"
    }
    
    if(!compatible){
        __tnt.log(status);
        
        if(window.ga){
            __tnt.trackEvent({'category':'tnt-adblock','action':'adblock','label':'adblock detected','value':'1'}); 
        
        }
    }
});
</script>

    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }
        });
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    </script>
    
<script>/*<![CDATA[*/ if ( TNCMS.User.isLoggedIn() ) {
/* user is logged in */
$("#newsbank .archive_search").append('<input type="hidden" name="d_vps" value="5900">');
} /*]]>*/</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script>/*<![CDATA[*/ !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script>/*<![CDATA[*/ var tnt_adTimerNum = 60000;
        var tnt_adTimerCalled = 0;
        var tnt_adTimer = setTimeout(tnt_adTimerEvent, tnt_adTimerNum);
        function tnt_adTimerEvent(){
            if( tnt_adTimerCalled === 10 ) {
                clearInterval(tnt_adTimerCalled);
            } else {
                try {
            
            var bOnlyDFP = false, bIsOAS = false;
            if( !bOnlyDFP && !bIsOAS && typeof TNCMS.AdManager != 'undefined' ){
                    TNCMS.AdManager.refresh({region: 'block-big-ad-side-rail-top-extra'});
                    TNCMS.AdManager.refresh({region: 'block-bottom-banner'});
                    TNCMS.AdManager.refresh({region: 'block-leaderboard-bottom'});
                    TNCMS.AdManager.refresh({region: 'block-leaderboard-bottom-mobile'});
                    TNCMS.AdManager.refresh({region: 'block-leaderboard-top'});
                    TNCMS.AdManager.refresh({region: 'block-leaderboard-top-mobile'});
                    TNCMS.AdManager.refresh({region: 'block-middle-banner'});
                    TNCMS.AdManager.refresh({region: 'block-right-rectangle'});
                    TNCMS.AdManager.refresh({region: 'block-right-rectangle-mid'});
                    TNCMS.AdManager.refresh({region: 'block-right-rectangle-bottom'});
                    TNCMS.AdManager.refresh({region: 'block-right-small-tile'});
                    TNCMS.AdManager.refresh({region: 'block-right-wide-skyscraper'});
                    TNCMS.AdManager.refresh({region: 'block-top-banner'});
                    TNCMS.AdManager.refresh({region: 'block-video'});
                    TNCMS.AdManager.refresh({region: 'fixed-aside-bottom-asset'});
                    TNCMS.AdManager.refresh({region: 'fixed-big-ad-bottom'});
                    TNCMS.AdManager.refresh({region: 'fixed-big-ad-bottom-asset'});
                    TNCMS.AdManager.refresh({region: 'fixed-big-ad-gallery'});
                    TNCMS.AdManager.refresh({region: 'fixed-big-ad-middle'});
                    TNCMS.AdManager.refresh({region: 'fixed-big-ad-middle-asset'});
                    TNCMS.AdManager.refresh({region: 'fixed-big-ad-top-asset'});
                    TNCMS.AdManager.refresh({region: 'fixed-impact-bottom'});
                    TNCMS.AdManager.refresh({region: 'fixed-impact-top'});
                    TNCMS.AdManager.refresh({region: 'pencil'});}
        } catch(e) {
            __tnt.log(e);
        }
                tnt_adTimer = setTimeout(tnt_adTimerEvent, tnt_adTimerNum);
            }
            tnt_adTimerCalled++;
        } /*]]>*/</script></body>
</html>